Pues eso, que parece que en la nueva versión del OS, no se dará soporte a versiones anteriores a SQL2005SP1:

In an effort to provide customers with more secure products, Microsoft Windows Server «Longhorn» and Microsoft Windows Vista supports only SQL Server 2005 with Service Pack 1 (SP1) or later. Earlier versions of SQL Server, including SQL Server 2000 (all editions), SQL Server 7.0, SQL Server 6.5, and MSDE will not be supported on Windows Server «Longhorn» or Windows Vista. Customers running applications with these earlier versions of SQL Server should consider evaluating and upgrading to SQL Server 2005 which was designed to take advantage of the upcoming security and performance enhancements in the operating environment.

Mi libre traducción:

«En nuestro esfuerzo por ofrecer a nuestros cliente productos más seguros, Windows Longhorn, y Windows Vista sólo serán soportados con SQL Server 2005 con SP1 o posterior. Versiones anteriores de SQL Server, incluyendo todas las ediciones de SQL Server 2000, 7.0, 6.5, y MSDE no serán soportadas en Lonhorn, y Vista. Los clientes deberán actualizarse a SQL Server 2005 que fué diseñado para beneficiarse de las mejoras de seguridad y rendimiento del nuevo entorno operativo…»

Más información en:
http://www.microsoft.com/sql/howtobuy/sqlonvista.mspx

http://www.siquelnet.com/default.aspx?Tema=NOTICIA&Seccion=GENERAL&Articulo=014

Bye

Eladio Rincón