Tal y como comentábamos en el post anterior, Microsoft sacó hace poco el primer Service Pack para SQL Server 2008, pero por algún error, al instalarlo se perdían algunos de los parches que el CU4 incluía. El caso es que para solucionar el problema, se acaba de publicar el primer parche acumulativo para SP1, descargable aquí.

En resumen, y tomando prestada la explicación que hace Aaron Bertrand en su blog, la cosa quedaría así:

  • Si tienes ya SP1 (2531), y actualizaste desde cualquier versión menor o igual que la 1787, no hay que hacer nada
  • Si tienes ya SP1 (2531) y actualizaste desde una versión superior a la 1787 y menor a la 2520, instalar SP1 CU1 (2710)
  • Si tienes actualmente SP1 CTP (2520), instalar SP1 (2531)
  • Si tienes actualmente CU4 (1798) o cualquier versión mayor de 1787 y menor de 2520, deberías instalar SP1 y posteriormente SP1 CU1 (2710)
  • Si tienes actualmente RTM (1600), CU1 (1763), CU2 (1779), CU3 (1787), o cualquier otra versión menor de 1787, debes instalar SP1 (2531)

Esperemos que no vuelvan a ocurrir cosas de este tipo.

SolidQ

SolidQ suministra servicios para plataformas Microsoft que le ayudan a diseñar, integrar y optimizar su utilización de datos